Identified
From our latest update from the bank, they have confirmed a service disruptions on Friday, March 27, from 5:00 p.m. to 5:30 p.m (GMT+1). The bank are currently investigating the issue.
Identified
Nationwide are still observing around ~35% failure for Nationwide AIS calls. They have escalated accordingly and updates will follow as soon as they are available.
Investigating
Nationwide are currently investigating an issue with their services.